Res mimetype 404 with net spa + angular

WebViewer Version: 8.4.0

Do you have an issue with a specific file(s)? Res files
Can you reproduce using one of our samples or online demos? No
Are you using the WebViewer server? No
Does the issue only happen on certain browsers? No
Is your issue related to a front-end framework? Yes
Is your issue related to annotations? No

Please give a brief summary of your issue:
I am using .net 6 SPA with angular 13. Locally, the web viewer works perfectly: it can load all files it requests from my angular assets folder. On dev, however, I get 404 from certain files, such as the PdfNet.res file. I have followed the instructions to add mime maps to my config in Startup.cs, but the problem is still present.

The app is deployed on azure app services using the --prod angular flag (if that matters).

Thank you!

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:

Guides:APIs:Forums:

Hi,

We’re looking into this issue, thanks for your patience.

Wanbo

Hi,

Please take a look at these links below and see if they help.

https://www.pdftron.com/documentation/web/guides/wv-server-azure-deployment/#quick-start-with-web-apps-for-containers
https://www.pdftron.com/documentation/web/guides/wv-server-azure-deployment/#azure-faq
https://stackoverflow.com/questions/58516095/azure-php-app-service-asset-folder-404-get-error
https://stackoverflow.com/questions/52570143/angular-app-on-azure-app-service-404-errors-when-loading-config-file-from-asse

Thanks.

Wanbo