Error with Erase Tool

Hello PDFTron!

I’m having this issue when use Erase Tool
It happens when I spend a long time and erase a lot of strokes without releasing the cursor

Also I can reproduce it on your demo

here link of the video

Hello, I’m Ron, an automated tech support bot :robot:

While you wait for one of our customer support representatives to get back to you, please check out some of these documentation pages:

Guides:APIs:Forums:

Hey Omar,

Thanks for providing the video.
I was able to reproduce it some of the time on our current demo.

I’m wondering if you try to reproduce the issue in our nightly WebViewer 8.0 experimental builds:

Thanks,
Anthony

Do you have any RC or alpha version for this?

Unfortunately at the moment, we do not.
But I can bring up your suggestion to the team.

Thanks,
Anthony

ok, thank you very much, it would be helpful to have an estimate of when it could be resolved or at least to be able to try an Alpha or RC version, to be able to comment it to our POs

For now, can you please try downloading the expiermental 8.0 build and double check on your end if the issue can be reproduced as I’m having trouble reproducing it.

THanks,
Anthony

Do you have a tutorial for using the nightly version?
I tried to replace all the folder and didn’t work

  1. extract all the files for the WebViewer 8.0 experimental nightly to a folder of your choice
  2. go to that folder and run npm install.
  3. it should give you a localhost URL to go to
  4. go to the localhost URL and try to reproduce the issue from there

Anthony

I was able to test it already, I can’t seem to reproduce the error anymore. Is there an estimate for version 8 to come out?

We aim to release 8.0 some time this month in the best case scenario.
In the worst case scenario, it will be released in July 2021.