Borders not shows right in a table in the produced PDF from a Word template

Product: PDFNet for Java

Product Version: 9.4.0

Please give a brief summary of your issue:
Borders not shows right in a table in the produced PDF from a Word template

Please describe your issue and provide steps to reproduce it:
We are producing PDF from a Word template.
One of the table with the problem looks like this in the template:

Aktive godkjenninger
{{loop aktiveGodkjenningerAdapterList}}

Godkjenningstype|{{godkjenningsType}}|
||{{godkjenningsbeskrivelse}}|
|Godkjent dato|{{godkjenningsDato}}|
|{{godkjentForMobileTjenesterLabel}}|{{godkjentForMobileTjenester}}|
|{{ansvarspersonLederType}}|{{tekniskeLedere}}|
|{{ansvarspersonStedfortrederType}}|{{tekniskeStedfortredere}}|
||{{endloop}}|

When the table is iterated several times, we can see that some of the borders is missing. This is when I produce this PDF on a Linux machine. If I produce the PDF on my Macbook pro Intel machine, all the borders are fine.

I could attach the Word template, but it does not look like that is possible. Also the generated PDF from both Linux and Mac

Not Ok, this is generated on Linux

This is ok and is generated on a Macbook pro with Intel.

This is the part of the template in use:

Sorry for the inconvenience about not being able to upload docx file. Please submit the following files to the form below (while I work to get the extensions allowed for upload updated).

  1. Input Word template file (e.g. docx)
  2. Template data (e.g. json)
  3. Generated PDF file

Support request filled. Have to upload the faulty PDF report generated on Linux tomorrow.